Allied Telesis iGS950/20PS Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Desktop/Wall-Mounting Silver
Price on request
We import this product on order. Send a request and we will reply with a confirmed price in Taka, import time and delivery date.
Request a price →Manufacturer page ↗Allied Telesis iGS950/20PS. Switch type: Managed, Switch layer: L2. Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000), Basic switching RJ-45 Ethernet ports quantity: 16. Full duplex. MAC address table: 8000 entries, Switching capacity: 40 Gbit/s. Networking standards: IEEE 802.1D, IEEE 802.1w, IEEE 802.1s, IEEE 802.1p, IEEE 802.3ad, IEEE 802.1x, IEEE 802.3at. Power over Ethernet (PoE). Wall mountable, Rack mounting, Form factor: Desktop/Wall-Mounting
Get it Thu, 12 Nov – Sat, 14 Nov (inside Dhaka)
Imported from abroad in about 3 days, then delivered to your door. Price includes import costs.
Delivery
Daily Delivery: Dhaka city ৳80 (instant, in-stock items) · All over Bangladesh ৳140 (within 24 hours) · Global products within 48 hours
Returns
7-day return for damaged, defective or wrong items. Policy
Ease of management and high performance
These advanced Allied Telesis WebSmart switches combine the simplicity of unmanaged switches with the performance and reliability of managed switches. This provides a cost-effective, secure and reliable solution for integrated management at the network edge. With user-friendly web-based management, the iGS950 Series is ideal for integrating simple management and security into your network solution.
Power over Ethernet (PoE)
The iGS950/10PS, 20PS, 28PS and 52PS switches are available in PoE+ (IEEE 802.3at), with the capability of delivering up to 30W per port. PoE allows users to connect and power a device using a single Ethernet cable, thus eliminating the need for additional power outlets and simplifying installation. Furthermore, this system is unaffected by any local variance in AC power, offering a standardized power infrastructure.
Specs Icecat
| Brand | Allied Telesis |
|---|---|
| Ethernet LAN data rates | 10,1000,100 Mbit/s |
| Product colour | Silver |
| Internal memory | 256 MB |
| Form factor | Desktop/Wall-Mounting |
| Switch type | Managed |
| Switch layer | L2 |
| Quality of Service (QoS) support | Yes |
| Web-based management | Yes |
| Configuring Location Settings (CLI) | Yes |
| MIB support | RFC 1213 MIB-II RFC 1643 Ethernet MIB RFC 1493 Bridge MIB RFC 2131 DHCPv4 server and client Private Enterprise MIB (Allied Telesis provides the spec) |
| Basic switching RJ-45 Ethernet ports quantity | 16 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Gigabit Ethernet (copper) ports quantity | 16 |
| Combo SFP ports quantity | 4 |
| Networking standards | IEEE 802.1D, IEEE 802.1w, IEEE 802.1s, IEEE 802.1p, IEEE 802.3ad, IEEE 802.1x, IEEE 802.3at |
| 10G support | No |
| Copper ethernet cabling technology | 10BASE-T, 100BASE-T, 1000BASE-T |
| Full duplex | Yes |
| Link aggregation | Yes |
| VLAN support | Yes |
| Number of VLANs | 256 |
| Fiber ethernet cabling technology | 100BASE-FX, 1000BASE-SX, 1000BASE-LX |
| Switching capacity | 40 Gbit/s |
| Forwarding rate | 29.8 Mpps |
| MAC address table | 8000 entries |
| Jumbo frames support | Yes |
| Jumbo frames | 10000 |
| Packet buffer memory | 0.512 MB |
| DHCP features | DHCP client |
| Access Control List (ACL) | Yes |
| Access Control List (ACL) IPv4 entries | 256 |
| IGMP snooping | Yes |
| SSH/SSL support | Yes |
| Multicast support | Yes |
| Rack mounting | Yes |
| Reset button | Yes |
| LED indicators | Yes |
| Wall mountable | Yes |
| Memory type | DRAM |
| Flash memory | 32 MB |
| Noise level | 51.7 dB |
| Telnet | Yes |
| Fanless | No |
| Power source | AC |
| AC input voltage | 100 - 240 V |
| AC input frequency | 50/60 Hz |
| Input current | 7 A |
| Power consumption (typical) | 22.6 W |
| Power consumption (max) | 434.3 W |
| Power plug type | Type F |
| Power over Ethernet (PoE) | Yes |
| Power over Ethernet (PoE) type supported | PoE+ |
| Power over Ethernet (PoE) ports quantity | 16 |
| Power over Ethernet plus (PoE+) ports quantity | 12 |
| Power over Ethernet (PoE) power per port | 30 W |
| Total Power over Ethernet (PoE) budget | 370 W |
| Size (imperial) | 48.3 cm (19") |
| Operating temperature (T-T) | -5 - 50 °C |
| Storage temperature (T-T) | -25 - 70 °C |
| Operating relative humidity (H-H) | 5 - 90% |
Specs Icecat (Open Icecat). Specifications are supplied by the manufacturer and provided as-is; please confirm details before ordering. Last verified 07 Nov 2026. Official product page ↗
No reviews yet. Be the first to review this product.









